Phishing E-Mails InterNetX / AutoDNS
Incident Report for InterNetX
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 00:19 CEST
Investigating
Unknown third parties are currently sending phishing emails in the name of InterNetX / AutoDNS. The content of these emails suggests that domains will be deleted shortly if they are not renewed immediately. The alleged domain renewal link is to a fraudulent phishing page which looks like the original AutoDNS Login page.

!!!
Please do not click on this link and do NOT enter any login details on websites you do not know.

Also delete this email immediately.
!!!

The official InterNetX websites are:

https://www.internetx.com
https://login.autodns.com
Posted May 30, 2024 - 17:05 CEST
This incident affected: AutoDNS (User Interface) and InterNetX Website.