Maintenance work ccTLD registry (Columbia)

Incident Report for InterNetX

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 15:12 CEST

Investigating

Due to a migration of backend services of the registry operator
for Columbia to a new plattform, domain orders for the TLD

.co

placed between

Thursday, October 2, 10:00 UTC and Tuesday, October 7, 10:00 UTC

may be executed with a delay.

Our services will be available again without restrictions after the
maintenance has been completed. Orders that are delayed due to this
maintenance will be processed as usual. If you have any questions,
please contact Domain Services at: domains@internetx.com / ☎ +49 941 59559 - 482
Posted Sep 24, 2025 - 12:37 CEST