Disruption - Redirection Service
Incident Report for InterNetX
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 12:27 CEST
Identified
We are currently investigating occasionally occurring issues with our mail redirection service to prevent blacklisting of domains.
Posted Apr 01, 2020 - 20:32 CEST
This incident affected: Domain Services (Redirector).