Disruption – Nameserver
Incident Report for InterNetX
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 09:18 CEST
Investigating
The nameserver d.ns14.net is currently affected due to a technical disruption – the system is temporarily restricted.

We have already taken appropriate measures and are working hard to resolve the situation. Full services will be available again shortly.

We apologize for any inconvenience and thank you for your understanding.
Posted Oct 22, 2021 - 07:31 CEST
This incident affected: Domain Services (Name Service) and Infrastructure (Data Center USA).